+2
Fixed

Location issues on ios11

boreasgirl 6 months ago • updated by slowGeorge 6 months ago 28

The app won’t take my location on iOS11. Can’t find it in the list of apps using the location either. Please fix this!

Under review

Just to confirm, you allowed location services in the settings, correct? What type of device are you using? It's working on my phone and our testing phones...so more details is helpful!


thanks!

Carla

Hi Carla. Thanks for getting back to me. 


In the meantime I have deleted the app and asked for a refund because there were even more issues, but I really loved the design and the functionality. 


Anyways, I am using an iPhone 7+ with all the latest updates.


As I said, I could not allow location services because where the app is supposed to give you the "Allow location services" pop-up, I only got grey screen with a yellow arrow which is supposed to show you where to click. I can only get out of it by restarting the app. I tried turning location services on and off (in privacy settings), I tried restarting the phone, I tried reinstalling the app - nothing works. If I look for Gratitude/Mojo or Gratitude under location services, it is not listed. In app permissions in phone settings I can only see photos, mobile data and Siri under Gratitude/Mojo. It shows some weird location/weather from half across the world from me, I guess it is where you are :) 


Other issues include the screen being cut from the side if I try to edit a note for example, but also on other occasions (as if it were only done for Iphone 7 screen) and the app generally being sluggish and crashing.


Please find some screenshots below, hope this helps.


Best,

Nastia



I have the identical problem. I’m running iOS 11 on my iPhone 6s. I don’t have the app listed for location services and have tried the same steps. 

I don’t know if it’s relevant but I’m in the uk and the app is called thegratitudeapp, not mojo. 

Please help. 

Fixed

Thanks for the screen shots...that's VERY helpful.


You will not find the app under Privacy. Rather, just go to your device SETTTINGS and scroll down. There you will find Gratitude and the opportunity for you to allow location.


Failing that, DELETE the app completely from your device and reinstall it.


Thanks for the layout issues. I'm aware of them and working on fixing them!


Carla :)

Sorry but this hasn’t fixed the problem for me. 


I’ve deleted the app and reinstalled


I scroll down to Gratitude in Settings and click on it.See below. 



I don’t have an option for location. 


 

Check Settings>General>Restrictions. Are enabled?

Restrictions are OFF. Should they be on?

Yes, turn them on and then it should work!

That didn’t work. 😥


I turned them on, deleted the app and reinstalled. Still no location services.

Restart your phone. It's hard to say because this comes down to settings, not the app.

No change I’m afraid. 


In case it helps, this screenshot is what happens when I click on Allow location in the app. 

Did not help me either, also since I have already done everything you suggested including reinstalling three times even before I wrote here. I could not see location in the settings-apps-gratitude, as the third screenshot I posted above shows. My restrictions were also on. 


I cannot download the app anymore without paying, since my refund went trough, so I cannot show you screenshots or give precise details, but I had the very same issue when I tried the app on iOS 11 on a first generation 12'' iPad Pro. 





I have the exact same problem- any fix/update?

Not for me.   I tried all the suggestions but location services is not an option in Settings for this app.

Go to your device settings > privacy > location services = ON

 Go to your device settings > General > Restrictions = Disabled

Go to your device settings > scroll down to Gratitude! > enable location

Most likely you're restricting access on your phone. 

Hi, thanks for replying but I’ve tried all the suggestions and it isn’t working. Gratitude isn’t showing in the device settings to enable me location etc. I can attach a screenshot if easier?

Apple introduced all sorts of new restrictions at a device level in iOS11...so you have to allow apps more...so it's down to your device, not the app...


Having said that...what type of device do you have? Perhaps that's the issue?


I tested this on all sorts of devices and once I allow the device access, the app works fine..but who knows?

It’s still not working for me. Screenshots below:

I’m on an iPhone  6s running ios 11.0.3


I downloaded the app from the U.K. store. Has the app been tested in different parts of the globe?  Could the restrictions be due to the country settings?

I have an iPhone 7 Plus

I’m also UK based

Those screenshots are exactly what I have on my phone too

It's been tested in Europe...so not sure if that's the case. Now that you have all access turned on, delete the app and reinstall it again, ok?

Hi, I’ve deleted and reinstalled 3 times now - no change

Hi Lisa - did you delete AFTER turning on all access? 

I’ve tried this too and it’s still not working.